Exporting Work

Once you have created the reflectance and illumination maps for an image, you have several options for saving and exporting your work. You can manipulate the illumination and reflectance maps separately within Lightbrush, or you can export the illumination and reflectance maps as images or as a layered document for editing in another application.

Saving Your Work

You can save all of your work from the developed original image to the reflectance and illumination maps, including any modifications with the interactive tools, in a single TGS file. You can save a TGS file at any time in the Factor phase and load it again later to pick up exactly where you left off.

To save your work in a TGS file, select Save (⌘S) from the File menu. Then use the standard OS X file interface to name the file and select where to put it.

Exporting Your Work

There are a number of options for exporting the original image, reflectance and illumination maps, both as files or directly to other programs. Under the File menu, selecting Export (⌘E) brings up a standard OS X file interface, as shown below (left). Clicking on the popup menu shows the possible export formats as below (right).

There are three primary export formats: 16-bit TIFF, 32-bit floating point EXR, and a Layered Adobe® Photoshop® Document. The layered document can be an 8-bit, 16-bit, or 32-bit per channel document. You can set the bit depth of the Layered Photoshop file in the application Preferences.

For both the TIFF and EXR formats, the reflectance map, illumination map, original image, and product image are each saved in a separate file. The original image has ‘.o’ before the file extension, the illumination image has ‘.i’, the reflectance image has ‘.r’, and the product image has ‘.p’.

The Layered Photoshop Document contains only the reflectance and the illumination as separate layers, multiplied together.

The Export To Photoshop option under the File menu creates a temporary layered Photoshop file containing the reflectance and illumination maps and tells OS X to open the file with the appropriate application.

The three parameters in the export dialog are multipliers on the respective images. It is not uncommon for values in the illumination or reflectance map to be larger than one, although their product should not be. The scale factors facilitate exporting to a TIFF image without clipping, allowing further manipulation.

Export to Photoshop

Lightbrush provides a simple way to export your work directly to Adobe Photoshop using a layered Photoshop Document that includes the illumination map and reflectance map as separate layers. Any application that can read a layered Photoshop file can manipulate the reflectance and illumination separately.

Once you have created the illumination and reflectance maps as separate images, you can use image manipulation software to modify them as desired. If you have Adobe Photoshop or another application that can read layered Photoshop files, Lightbrush makes it easy to send the application a multi-layer document to enable manipulation of the intrinsic components.

To export the reflectance and illumination maps as a layered document, select Export To Photoshop from the File menu. Lightbrush will create a temporary file and tell Mac OS X to open the file using an appropriate application, if one is installed.

The export file will have three layers: the reflectance map layer, the illumination map layer, and a display gamma adjustment layer. The reflectance map and illumination map layers have a multiply relationship, and the display gamma adjustment layer applies a gamma compression identical to the display gamma in Lightbrush. The combination of the three layers should produce an image that is identical the the original image displayed in Lightbrush.

Once the file is open in Photoshop, you can make any of the three layers visible or invisible, manipulate the layers independently, and export a single layer or a combination of the layers to another file. For example, you could gamma compress the illumination to brighten the shadows and scale the reflectance to increase the contrast of the material colors.

Color Setup

In order to match the appearance of the image in Lightbrush and Adobe Photoshop, it is important to set up color management correctly in Photoshop after exporting the
file.
1) Under the View menu in Photoshop, go to the Proof Setup sub-menu and select Monitor RGB.
2) Under the View menu in Photoshop, select Proof Colors.

The image should now look virtually identical in the two applications, and you can use all of the available tools to independently manipulate the lighting and material colors of the objects in your scene.